It happens from time to time that an Eclipse-based IDE might need to use a version of Java other than the one on your classpath. It’s pretty simple to set this up in your eclipse.ini file – or whichever configuration file your specific Eclipse-based IDE may use.

Here’s what you need to have as the first line in your config file –

And that’s it!

Enjoy.